14 October 2014

Error When Running Crystal Server 2013 wdeploy Tool

The error:
2014-10-14 14:09:32,031   Target - Target "deployall" finished with error.
D:\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\wdeploy\wcommon.xml:361: The following error occurred while executing this line:
D:\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\wdeploy\wcommon.xml:310: The following error occurred while executing this line:
D:\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\wdeploy\wcommon.xml:1948: The following error occurred while executing this line:
D:\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\wdeploy\wcommon.xml:764: Execute failed: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:541)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:418)
at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:357)
at org.apache.tools.ant.Target.performTasks(Target.java:385)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
at org.apache.tools.ant.Main.runBuild(Main.java:698)
at org.apache.tools.ant.Main.startAnt(Main.java:199)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

Solution:
Check your server's environment variable, ensure JAVA_HOME is all caps, mine had error because it was JAVA_Home, by changing all to upper case it worked!

No comments: